2013年7月2日

安裝 html2jade 筆記

原來竟然有 html2jade 這種東西,以前都是手動改寫,太花時間了

但是安裝過程意外的問題重重,以下筆記

首先nodejs 要更新,更新時才發現原來已經到 node v0.10.12了呀,我還在 v0.8.x 的時代

之後 npm 也要更新

python 要使用2.7以上,尤其要檢查/usr/local/bin/python 的版本對應,不然會出現 Import Error: 找不到 multiprocessor

然後python對應正確後要重新安裝node-gyp,非常重要的一點是,要先清除cache!


git clone http://github.com/isaacs/npm.git cd npm sudo make install

sudo npm rm -g node-gyp npm clean cache sudo npm install -g node-gyp sudo npm install -g html2jade