2012年9月10日

正確重新安裝PIL on Ubuntu

之前PIL安裝完還是遇到zlib沒有被支援的問題

環境Ubuntu 12.0.4


先移除 sudo pip uninstall PIL 安裝必要套件和PIL所需的path sudo apt-get install libjpeg8 libjpeg62-dev libfreetype6 libfreetype6-dev sudo ln -s /usr/lib/x86_64-linux-gnu/libjpeg.so /usr/lib sudo ln -s /usr/lib/x86_64-linux-gnu/libfreetype.so /usr/lib sudo ln -s /usr/lib/x86_64-linux-gnu/libz.so /usr/lib 重新安裝 sudo pip install -U PIL 安裝完成 -------------------------------------------------------------------- PIL 1.1.7 SETUP SUMMARY -------------------------------------------------------------------- version 1.1.7 platform linux2 2.7.3 (default, Apr 20 2012, 22:39:59) [GCC 4.6.3] -------------------------------------------------------------------- *** TKINTER support not available --- JPEG support available --- ZLIB (PNG/ZIP) support available --- FREETYPE2 support available *** LITTLECMS support not available --------------------------------------------------------------------
reference1